【解決済み】チャット機能で障害が発生していました
Incident Report for KARTE
Postmortem

■ 発生期間

2021/12/13 13:05頃~2021/12/14 12:20頃

■ 対象プロジェクト

  • チャットをネイティブアプリで利用中の全プロジェクト

■ 対象機能

  • KARTE Talkのチャット機能

■ 発生した現象

  • エンドユーザー側からメッセージの参照ができない

  • エンドユーザー側のタイピングステータスがオペレーターに伝わらない

■ 原因

  • 新たに追加した計測タグの移行処理にて、ネイティブアプリからチャット機能を使うための内部データが正しくチャット機能に連携されなくなっていた

    • 計測タグ修正の影響範囲調査時に、ネイティブアプリからのデータ連携経路を考慮できていなかった

■ 実施した対応

  • 新たに追加した移行処理を元に戻し、内部データを正しく連携するようにした

■ 今後の対応

  • 計測タグ修正時にネイティブアプリ関連の影響範囲把握に漏れがないようレビュー体制を強化する

  • ネイティブアプリとチャット機能などの内部データ連携処理の自動テストを追加する

    • 障害の検知が遅れた件について、チャット機能の障害を素早く検知できるよう監視を強化する

この度はご迷惑をおかけしてしまい、誠に申し訳ございませんでした。

Posted Dec 14, 2021 - 14:25 JST

Resolved
障害が解消したのでご報告します。

■ 発生期間
2021/12/13 13:05頃~2021/12/14 12:20頃


■ 対象プロジェクト
- チャットをネイティブアプリで利用中の全プロジェクト

■ 対象機能
- KARTE Talkのチャット機能

■ 発生した現象
- エンドユーザー側からメッセージの参照ができない
- エンドユーザー側のタイピングステータスがオペレーターに伝わらない

■ 原因
- 新たに追加した計測タグの移行処理にて、ネイティブアプリからチャット機能を使うための内部データが正しくチャット機能に連携されなくなっていた

■ 実施した対応
- 新たに追加した移行処理を元に戻し、内部データを正しく連携するようにした

この度はご迷惑をおかけし、大変申し訳ございませんでした。
なお、本障害の詳細や事後対応については、追って記載します。
Posted Dec 14, 2021 - 13:31 JST
Monitoring
チャット機能の一部で障害が発生していました。
すでに本障害の解決に向けた対応を実施しました。

■ 対象プロジェクト
- チャットをネイティブアプリで利用中の全プロジェクト

■ 対象機能
- KARTE Talkのチャット機能

■ 発生した現象
- 送信したチャットの内容が一部表示されない

現在、障害の解決を確認するために監視を続けています。
約1時間以内に続報を掲載します。
Posted Dec 14, 2021 - 12:29 JST
This incident affected: チャット.